Degraded performance - Namirial Signing Service

Incident Report for WebID Solutions Statuspage

Resolved

The Problem has been solved
Posted May 18, 2026 - 12:11 CEST

Update

We are continuing to investigate this issue.
Posted May 18, 2026 - 12:10 CEST

Investigating

Our TSP, Namirial, has informed us about degraded performance affecting document signing. All integration partners using Namirial Signing Service may be impacted. Namirial is currently working on the issue. We will keep you updated.
Posted May 18, 2026 - 11:44 CEST
This incident affected: WebID Products (AccountID, SignID, SignID Direct).