The safety fire drill was executed successfully. There were no further service interruptions. We appreciate your understanding.
Posted Dec 08, 2025 - 09:10 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 08, 2025 - 09:01 CET
Scheduled
Description: As part of our regular safety and emergency preparedness program, a scheduled fire safety drill will be conducted at the VSC Solingen site during the above-mentioned maintenance window.
As a result of the fire drill, short-term increased waiting times may occur. No production systems will be shut down; however, minor delays cannot be fully excluded.
It's important to note that this drill does not impact our partners' video service centers.
Expected Impact: - Temporarily longer waiting times during the specified maintenance window - Short-term reduced reachability - No service shutdown planned - No data loss expected - All security and monitoring systems remain active
Purpose: This exercise is an essential part of WebID Solutions’ Business Continuity and emergency preparedness strategy. As this drill directly contributes to the stability and resilience of our services, we apologize for any inconvenience this mandatory fire drill may cause and appreciate your understanding.
Posted Dec 08, 2025 - 07:56 CET
This scheduled maintenance affected: WebID Products (VideoID, VisualID).